For the complete documentation index, see llms.txt. This page is also available as Markdown.

Startup the CN

CN Start/Stop

You can start/stop the Klaytn service with the following systemctl command.

Note: This requires root privileges.

start

$ systemctl start kcnd.service

stop

$ systemctl stop kcnd.service

status

$ systemctl status kcnd.service

Troubleshooting

If you meet the following error,

Failed to start kcnd.service: Unit not found.

reload the systemd manager configuration with the following command.

Export BLS public key info

If the network has activated or will activate the Randao hardfork, each CN maintainer must submit its BLS public key info to the KIP-113 smart contract.

The BLS public key info can be calculated from the nodekey. To extract it, first start the node. Then use the command:

As a result, bls-publicinfo-NODEID.json file will be created.

Last updated